FreeBSD Initial Preparation

By admin, 27 April, 2025

Writing FreeBSD iso to a blank disc via the following command (Recommended):

# dmesg | egrep -i 'cd|dvd'
# growisofs -dvd-compat -Z /dev/sr0=imagefile.iso

FreeBSD release fresh install including with the following parameters:

Hostname - wsx64 / Fullname - Pars Enterprise / Username - parsenterprise

Adding user to wheel or sudo group as a superuser via the following commands:

  • Login as root
  • Editing /usr/local/etc/sudoers with Administration Privilege to:

Uncomment the following line to allow members of group wheel to execute any command:

%sudo ALL=(ALL:ALL) ALL
Or executing: sudo pw groupmod sudo -m

Editing /etc/sysctl.conf with Administration Privilege to:

net.local.stream.recvspace=65536

net.local.stream.sendspace=65536

Deleting .core Files in Home Directory

Prevent coredumps by editing /etc/sysctl.conf with Administration Privilege to:

kern.coredump=0

or reroute them by: kern.corefile=/dev/null

FreeBSD Repository Preferences

Stable – Quarterly – Latest - Current

Editing /etc/pkg/FreeBSD.conf or /usr/local/etc/pkg/repos/FreeBSD.conf with Administration Privilege

Pars Enterprise Platforms /boot/loader.conf (/boot/defaults/loader.conf) Configurations

autoboot_delay="3"
beastie_disable="YES"
boot_mute=”YES”
loader_delay="0"
loader_logo="none"

Pars Enterprise Platforms /etc/rc.conf (/etc/defaults/rc.conf) Configurations

dbus_enable="YES"
hald_enable="YES"
kld_list="i915kms"
sddm_enable="YES"
webcamd_enable="YES"

Desktop Environment Installation

# pkg install x11/kde5

To instead build the KDE port, use the following command. Installing the port will provide a menu for selecting which components to install. KDE is a large application and will take some time to compile, even on a fast computer.

# cd /usr/ports/x11/kde5
# make install clean

or via installation disc or internet:

Create a /dist directory and mount the DVD.

# mkdir -p /dist
# mount -t cd9660 /dev/cd0 /dist

Make sure REPOS_DIR is correctly pointing to your local repository.

# export REPOS_DIR=/dist/packages/repos

or for csh:

# setenv REPOS_DIR /dist/packages/repos

Bootstrap pkg and install packages.

# sudo pkg bootstrap
# sudo pkg install nano sudo xorg kde5 sddm octopkg xf86-video-intel

KDE requires /proc to be mounted. Add this line to /etc/fstab to mount this file system automatically during system startup:

proc /proc procfs rw 0 0

KDE uses D-Bus and HAL for a message bus and hardware abstraction. These applications are automatically installed as dependencies of KDE. Enable them in /etc/rc.conf so they will be started when the system boots:

dbus_enable="YES"
hald_enable="YES"

Since KDE Plasma 5, the KDE Display Manager, KDM is no longer developed. A possible replacement is SDDM. To install it, type:

# pkg install x11/sddm

Add this line to /etc/rc.conf:

sddm_enable="YES"

A second method for launching KDE is to type startx from the command line. For this to work, the following line is needed in ~/.xinitrc:

exec ck-launch-session startkde

A third method for starting KDE is through XDM. To do so, create an executable ~/.xsession as follows:

% echo "exec ck-launch-session startkde" > ~/.xsession

Once KDE is started, refer to its built-in help system for more information on how to use its various menus and applications.

LAME in FreeBSD is required by some of multimedia applications and needed to be installed manually from ports:

LAME is an highly evolved LGPL MP3 encoder with quality and speed able to rival state of the art commercial encoders.

To install the port: cd /usr/ports/audio/lame/ && make install clean